Citizens of the Imperium

Citizens of the Imperium (http://www.travellerrpg.com/CotI/Discuss/index.php)
-   Traveller: The New Era (http://www.travellerrpg.com/CotI/Discuss/forumdisplay.php?f=40)
-   -   Twilight (http://www.travellerrpg.com/CotI/Discuss/showthread.php?t=7339)

RASH June 15th, 2003 04:24 PM

Actually I do not own a copy of Traveller, I have just heard that the rules are somewhat compatible to Twiligth2000 and Dark Conspiracy. Can somebody please tell me if this is true and if so to what degree?

I would very much appreciate that.

Secrect Cow Level June 15th, 2003 05:40 PM

TRAVELLER: The New Era is totally compatable with TWILIGHT 2000 2nd Edition version 2.2 and DARK CONSPIRACY. TWILIGHT 2000 2nd Edition version 2.0 is largly compatable, except it uses a d10 for tasks instead of a d20 if I'm not mistaken. Large portions of the the TNE rulebook were lifted directly from the TWILIGHT 2000 rulebook (especially the combat and wilderness survival sections). So if you know how to play one of these games you know how to play all three! [img]smile.gif[/img]

Antony June 17th, 2003 02:13 AM

The Dark Conspiracy rules also had a booster set which converted them to the d20 system used by the Twilight and TNE versions. Dark Conspiracy is close enough to TNE that I have run encounters with things like Greater Pales in a Traveller game with no problems at all.


All times are GMT -4. The time now is 12:54 PM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2010-2013, Far Future Enterprises. All Rights Reserved.